]> git.bzium.org - embe/overlay.git/blob - app-portage/eix/eix-9999.ebuild
Podbicie EAPI do 5: app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=5
5
6 EGIT_REPO_URI="git://git.berlios.de/eix"
7
8 WANT_LIBTOOL="none"
9
10 PLOCALES="de ru"
11 inherit autotools git-2 bash-completion-r1 eutils multilib l10n
12
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="http://eix.berlios.de"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
20
21 RDEPEND="app-shells/push
22         sqlite? ( >=dev-db/sqlite-3 )
23         nls? ( virtual/libintl )"
24 DEPEND="${RDEPEND}
25         clang? ( sys-devel/clang )
26         doc? ( dev-python/docutils )
27         sys-devel/gettext"
28
29 src_prepare() {
30         epatch_user
31         eautopoint
32         eautoreconf
33 }
34
35 src_configure() {
36         econf $(use_with sqlite) $(use_with doc extra-doc) \
37                 $(use_with zsh-completion) \
38                 $(use_enable nls) $(use_enable tools separate-tools) \
39                 $(use_enable security) $(use_enable optimization) \
40                 $(use_enable strong-optimization) $(use_enable debug debugging) \
41                 $(use_with prefix always-accept-keywords) \
42                 $(use_with dep dep-default) \
43                 $(use_with clang nongnu-cxx clang++) \
44                 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
45                 --with-portage-rootpath="${ROOTPATH}" \
46                 --with-eprefix-default="${EPREFIX}" \
47                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
48                 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
49 }
50
51 src_install() {
52         default
53         dobashcomp bash/eix
54         keepdir "/var/cache/${PN}"
55         fowners portage:portage "/var/cache/${PN}"
56         fperms 775 "/var/cache/${PN}"
57 }
58
59 pkg_postinst() {
60         # fowners in src_install doesn't work for owner/group portage:
61         # merging changes this owner/group back to root.
62         use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
63         local obs="${EROOT}var/cache/eix.previous"
64         ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
65 }