]> git.bzium.org - embe/overlay.git/blob - sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.56.ebuild
Usunięcie dev-libs/libgcrypt
[embe/overlay.git] / sys-apps / rescan-scsi-bus / rescan-scsi-bus-1.56.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/rescan-scsi-bus/rescan-scsi-bus-1.48.ebuild,v 1.1 2011/02/02 09:30:32 robbat2 Exp $
4
5 inherit eutils
6
7 DESCRIPTION="Script to rescan the SCSI bus without rebooting"
8 HOMEPAGE="http://www.garloff.de/kurt/linux/"
9 SCRIPT_NAME="${PN}.sh"
10 SRC_NAME="${SCRIPT_NAME}-${PV}"
11 SRC_URI="http://www.garloff.de/kurt/linux/${SRC_NAME}"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=""
19 RDEPEND=">=sys-apps/sg3_utils-1.24"
20
21 S="${WORKDIR}"
22
23 src_unpack() {
24         cp -f "${DISTDIR}"/${SRC_NAME} "${WORKDIR}"/${SCRIPT_NAME}
25 }
26
27 src_compile() {
28         :
29 }
30
31 src_install() {
32         into /usr
33         dosbin ${SCRIPT_NAME}
34         # Some scripts look for this without the trailing .sh
35         # Some look for it with the trailing .sh, so have a symlink
36         dosym ${SCRIPT_NAME} /usr/sbin/${PN}
37 }