]> git.bzium.org/ - embe/overlay.git/blob - dev-python/jsonlines/jsonlines-4.0.0.ebuild
dev-python/jsonlines-4.0.0: bump
[embe/overlay.git] / dev-python / jsonlines / jsonlines-4.0.0.ebuild
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=8
5
6 DISTUTILS_USE_PEP517=setuptools
7 PYTHON_COMPAT=( python3_{10..12} )
8 inherit distutils-r1
9
10 DESCRIPTION="Python library to simplify working with jsonlines and ndjson data"
11 HOMEPAGE="https://github.com/wbolster/jsonlines"
12 SRC_URI="https://github.com/wbolster/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="BSD"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
18
19 distutils_enable_sphinx doc
20 distutils_enable_tests pytest