1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="https://github.com/vaeth/eix.git"
11 inherit autotools git-r3 bash-completion-r1 l10n systemd
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="https://github.com/vaeth/eix/"
19 IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
21 BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
22 nls? ( virtual/libintl )"
23 RDEPEND="${BOTHDEPEND}
27 doc? ( dev-python/docutils )
28 >=sys-devel/gettext-0.18.3"
31 sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
37 econf $(use_with sqlite) $(use_with doc extra-doc) \
38 $(use_enable nls) $(use_enable tools separate-tools) \
39 $(use_enable security) $(use_enable optimization) \
40 $(use_enable strong-security) \
41 $(use_enable strong-optimization) $(use_enable debug debugging) \
42 $(use_enable swap-remote) \
43 $(use_with prefix always-accept-keywords) \
44 $(use_with dep dep-default) \
45 $(use_with required-use required-use-default) \
46 --with-zsh-completion \
47 --with-portage-rootpath="${ROOTPATH}" \
48 --with-eprefix-default="${EPREFIX}"
54 systemd_dotmpfilesd tmpfiles.d/eix.conf
58 test -d "${EROOT}var/cache/${PN}" || {
59 mkdir "${EROOT}var/cache/${PN}"
60 use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
62 local obs="${EROOT}var/cache/eix.previous"
63 ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
67 [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"