]> git.bzium.org - embe/overlay.git/blob - app-portage/eix/eix-9999.ebuild
Nowy pakiet: app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=3
5
6 ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
7 ESVN_BOOTSTRAP="./autogen.sh"
8
9 WANT_AUTOMAKE="1.11"
10
11 inherit autotools multilib subversion
12
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="http://eix.berlios.de"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="+bzip2 debug doc hardened nls optimization strong-optimization sqlite tools"
20
21 RDEPEND="sqlite? ( dev-db/sqlite:3 )
22         nls? ( virtual/libintl )
23         bzip2? ( app-arch/bzip2 )"
24 DEPEND="${RDEPEND}
25         doc? ( dev-python/docutils )
26         sys-devel/gettext"
27
28 src_configure() {
29         econf $(use_with bzip2) $(use_with sqlite) $(use_with doc rst) \
30                 $(use_enable nls) $(use_enable tools separate-tools) \
31                 $(use_enable hardened security) $(use_enable optimization) \
32                 $(use_enable strong-optimization) $(use_enable debug debugging) \
33                 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
34                 --with-portage-rootpath="${ROOTPATH}" \
35                 --with-eprefix-default="${EPREFIX}" \
36                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
37                 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
38 }
39
40 src_install() {
41         emake DESTDIR="${D}" install || die "emake install failed"
42         prepalldocs
43 }