1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
7 ESVN_BOOTSTRAP="./autogen.sh"
11 inherit autotools multilib subversion
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="http://eix.berlios.de"
19 IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
21 RDEPEND="sqlite? ( dev-db/sqlite:3 )
22 nls? ( virtual/libintl )
23 bzip2? ( app-arch/bzip2 )
24 zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
26 doc? ( dev-python/docutils )
30 econf $(use_with bzip2) $(use_with sqlite) $(use_with doc extra-doc) \
31 $(use_with zsh-completion) \
32 $(use_enable nls) $(use_enable tools separate-tools) \
33 $(use_enable hardened security) $(use_enable optimization) \
34 $(use_enable strong-optimization) $(use_enable debug debugging) \
35 $(use_with prefix always-accept-keywords) \
36 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
37 --with-portage-rootpath="${ROOTPATH}" \
38 --with-eprefix-default="${EPREFIX}" \
39 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
40 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"