]> git.bzium.org - embe/overlay.git/blob - app-crypt/certbot-dns-cloudflare/certbot-dns-cloudflare-1.9.0.ebuild
dev-python/cloudflare: bump to 2.8.14 with Python 3.9 support
[embe/overlay.git] / app-crypt / certbot-dns-cloudflare / certbot-dns-cloudflare-1.9.0.ebuild
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5 PYTHON_COMPAT=( python3_{6,7,8} )
6 DISTUTILS_USE_SETUPTOOLS=rdepend
7
8 inherit distutils-r1
9
10 DESCRIPTION="Cloudflare DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
11 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
12 SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 S=${WORKDIR}/certbot-${PV}/${PN}
14
15 LICENSE="Apache-2.0"
16 SLOT="0"
17 KEYWORDS="~amd64"
18
19 RDEPEND="
20         app-crypt/acme[${PYTHON_USEDEP}]
21         app-crypt/certbot[${PYTHON_USEDEP}]
22         dev-python/cloudflare[${PYTHON_USEDEP}]
23         dev-python/zope-interface[${PYTHON_USEDEP}]
24 "
25
26 distutils_enable_tests pytest
27 distutils_enable_sphinx docs dev-python/sphinx_rtd_theme