]> git.bzium.org - embe/overlay.git/blob - dev-python/jsonlines/jsonlines-2.0.0.ebuild
PYTHON_COMPAT update
[embe/overlay.git] / dev-python / jsonlines / jsonlines-2.0.0.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{8..10} )
7 inherit distutils-r1
8
9 DESCRIPTION="Python library to simplify working with jsonlines and ndjson data"
10 HOMEPAGE="https://github.com/wbolster/jsonlines"
11 SRC_URI="https://github.com/wbolster/jsonlines/archive/${PV}.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="~amd64"
16
17 distutils_enable_tests pytest
18 distutils_enable_sphinx doc