]> git.bzium.org - embe/overlay.git/blob - dev-python/cloudflare/cloudflare-2.8.13.ebuild
dev-python/jsonlines: Python 3.9 support
[embe/overlay.git] / dev-python / cloudflare / cloudflare-2.8.13.ebuild
1 # Copyright 2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=7
5
6 PYTHON_COMPAT=( python3_{6,7,8} )
7 DISTUTILS_USE_SETUPTOOLS=rdepend
8 inherit distutils-r1
9
10 MY_PN="python-${PN}"
11 MY_P="${MY_PN}-${PV}"
12
13 DESCRIPTION="Python wrapper for the Cloudflare Client API v4"
14 HOMEPAGE="https://github.com/cloudflare/python-cloudflare"
15 SRC_URI="https://github.com/cloudflare/${MY_PN}/archive/${PV}.tar.gz -> ${MY_P}.tar.gz"
16
17 LICENSE="MIT-with-advertising"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE="examples"
21
22 RDEPEND="
23         dev-python/requests[${PYTHON_USEDEP}]
24         dev-python/pyyaml[${PYTHON_USEDEP}]
25         dev-python/jsonlines[${PYTHON_USEDEP}]
26         dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
27 "
28
29 S="${WORKDIR}/${MY_P}"
30
31 src_prepare() {
32         sed -i -e "s:packages=.*:packages=['cli4', 'CloudFlare'],:" -i setup.py || die
33         sed -i -e "/data_files = /d" -i setup.py || die
34         distutils-r1_src_prepare
35 }
36
37 python_install_all() {
38         if use examples; then
39                 dodoc -r examples
40                 docompress -x /usr/share/doc/${PF}/examples
41         fi
42
43         newman cli4/cli4.man cli4.1
44
45         distutils-r1_python_install_all
46 }