1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="https://github.com/vaeth/eix.git"
11 inherit autotools git-r3 bash-completion-r1 eutils l10n
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="https://github.com/vaeth/eix/"
19 IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
21 BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
22 nls? ( virtual/libintl )"
23 RDEPEND="${BOTHDEPEND}
26 doc? ( dev-python/docutils )
27 >=sys-devel/gettext-0.18.3"
30 sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf
36 econf $(use_with sqlite) $(use_with doc extra-doc) \
37 $(use_enable nls) $(use_enable tools separate-tools) \
38 $(use_enable security) $(use_enable optimization) \
39 $(use_enable strong-security) \
40 $(use_enable strong-optimization) $(use_enable debug debugging) \
41 $(use_enable swap-remote) \
42 $(use_with prefix always-accept-keywords) \
43 $(use_with dep dep-default) \
44 --with-zsh-completion \
45 --with-portage-rootpath="${ROOTPATH}" \
46 --with-eprefix-default="${EPREFIX}" \
47 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
48 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
54 insinto "/usr/lib/tmpfiles.d"
55 doins tmpfiles.d/eix.conf
59 test -d "${EROOT}var/cache/${PN}" || {
60 mkdir "${EROOT}var/cache/${PN}"
61 use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
63 local obs="${EROOT}var/cache/eix.previous"
64 ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
68 [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"