]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 243a93a970de6c813ed32c14e94467ee7fa06f1b..be574197a10aa7100322343e4fbd1470e28d3814 100644 (file)
@@ -7,7 +7,9 @@ EGIT_REPO_URI="git://git.berlios.de/eix"
 
 WANT_LIBTOOL="none"
 
-inherit autotools git-2 multilib bash-completion-r1
+PLOCALES="de ru"
+
+inherit autotools git-2 bash-completion-r1 eutils multilib l10n
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -15,17 +17,18 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
 
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )
-       app-shells/push
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+RDEPEND="app-shells/push
+       sqlite? ( >=dev-db/sqlite-3 )
+       nls? ( virtual/libintl )"
 DEPEND="${RDEPEND}
+       clang? ( sys-devel/clang )
        doc? ( dev-python/docutils )
        sys-devel/gettext"
 
 src_prepare() {
+       epatch_user
        eautopoint
        eautoreconf
 }
@@ -38,6 +41,7 @@ src_configure() {
                $(use_enable strong-optimization) $(use_enable debug debugging) \
                $(use_with prefix always-accept-keywords) \
                $(use_with dep dep-default) \
+               $(use_with clang nongnu-cxx clang++) \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \