]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Nowy adres repozytorium app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index d6be4e2c3ad07b462552aeb7ba9a6089ba300f34..dfce60a790fb08c25d361563fb6f12881a3f22f0 100644 (file)
@@ -1,15 +1,15 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
 
-EGIT_REPO_URI="git://git.berlios.de/eix"
+EGIT_REPO_URI="https://github.com/vaeth/eix.git"
 
 WANT_AUTOMAKE="1.13"
 WANT_LIBTOOL="none"
 
 PLOCALES="de ru"
-inherit autotools git-2 bash-completion-r1 eutils multilib l10n
+inherit autotools git-r3 bash-completion-r1 eutils multilib l10n
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -17,15 +17,15 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools zsh-completion"
+IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
 
-RDEPEND="app-shells/push
-       sqlite? ( >=dev-db/sqlite-3 )
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
        nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
-       clang? ( sys-devel/clang )
+RDEPEND="${BOTHDEPEND}
+       app-shells/push"
+DEPEND="${BOTHDEPEND}
        doc? ( dev-python/docutils )
-       sys-devel/gettext"
+       >=sys-devel/gettext-0.18.3"
 
 src_prepare() {
        epatch_user
@@ -34,7 +34,6 @@ src_prepare() {
 
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
-               $(use_with zsh-completion) \
                $(use_enable nls) $(use_enable tools separate-tools) \
                $(use_enable security) $(use_enable optimization) \
                $(use_enable strong-security) \
@@ -42,7 +41,7 @@ src_configure() {
                $(use_enable swap-remote) \
                $(use_with prefix always-accept-keywords) \
                $(use_with dep dep-default) \
-               $(use_with clang nongnu-cxx clang++) \
+               --with-zsh-completion \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \