]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 22545fd00db0887a4a9c873abb7d782f783b0fe2..08502e53b9f67f87b739dc543f74d022b7082c30 100644 (file)
@@ -4,7 +4,6 @@
 EAPI=4
 
 EGIT_REPO_URI="git://git.berlios.de/eix"
-EGIT_BOOTSTRAP="autogen.sh"
 
 WANT_LIBTOOL="none"
 
@@ -25,6 +24,11 @@ DEPEND="${RDEPEND}
        doc? ( dev-python/docutils )
        sys-devel/gettext"
 
+src_prepare() {
+       eautopoint
+       eautoreconf
+}
+
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
                $(use_with zsh-completion) \
@@ -43,19 +47,15 @@ src_configure() {
 src_install() {
        default
        dobashcomp bash/eix
-       keepdir /var/cache/eix
-       fowners portage:portage /var/cache/eix
-}
-
-pkg_preinst() {
-       for file in "${EROOT}"/var/cache/eix{,.previous}
-       do
-               [ ! -f "${file}" ] && continue
-               rm "${file}" || die "Removing ${file} failed."
-       done
+       keepdir "/var/cache/${PN}"
+       fowners portage:portage "/var/cache/${PN}"
+       fperms 775 "/var/cache/${PN}"
 }
 
 pkg_postinst() {
-       # src_install zmienia portage na root
-       chown portage:portage "${EROOT}/var/cache/eix"
+       # fowners in src_install doesn't work for owner/group portage:
+       # merging changes this owner/group back to root.
+       use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       local obs="${EROOT}var/cache/eix.previous"
+       ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
 }