]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 2fe3a50f770a4789db2d918ef9fab3ec6b300954..4d24bd46e3a58c613caf0d6ac7a8aa531bb9c5db 100644 (file)
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=6
 
-ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
-ESVN_BOOTSTRAP="./autogen.sh"
+EGIT_REPO_URI="https://github.com/vaeth/eix.git"
 
-WANT_AUTOMAKE="1.11"
+WANT_LIBTOOL="none"
 
-inherit autotools multilib subversion
+PLOCALES="de ru"
+inherit autotools git-r3 bash-completion-r1 l10n systemd
 
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
-HOMEPAGE="http://eix.berlios.de"
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
+IUSE="debug doc nls sqlite"
 
-RDEPEND="sqlite? ( dev-db/sqlite:3 )
-       nls? ( virtual/libintl )
-       bzip2? ( app-arch/bzip2 )
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
-DEPEND="${RDEPEND}
+BOTHDEPEND="nls? ( virtual/libintl )
+       sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+       >=app-shells/push-2.0
+       >=app-shells/quoter-3.0"
+DEPEND="${BOTHDEPEND}
        doc? ( dev-python/docutils )
-       sys-devel/gettext"
+       >=sys-devel/gettext-0.18.3"
+
+pkg_setup() {
+       # remove stale cache file to prevent collisions
+       local old_cache=${EROOT%/}/var/cache/${PN}
+       if [[ -f ${old_cache} ]]; then
+               rm "${old_cache}" || die
+       fi
+}
+
+src_prepare() {
+       default
+       sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
+       eautoreconf
+}
 
 src_configure() {
-       econf $(use_with bzip2) $(use_with sqlite) $(use_with doc extra-doc) \
-               $(use_with zsh-completion) \
-               $(use_enable nls) $(use_enable tools separate-tools) \
-               $(use_enable hardened security) $(use_enable optimization) \
-               $(use_enable strong-optimization) $(use_enable debug debugging) \
-               --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
-               --with-portage-rootpath="${ROOTPATH}" \
-               --with-eprefix-default="${EPREFIX}" \
-               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+       local myconf=(
+               $(use_enable debug paranoicasserts)
+               $(use_enable nls)
+               $(use_with doc extra-doc)
+               $(use_with sqlite)
+
+               # default configuration
+               $(use_with prefix always-accept-keywords)
+               --with-dep-default
+               --with-required-use-default
+
+               # paths
+               --with-portage-rootpath="${ROOTPATH}"
+               --with-eprefix-default="${EPREFIX}"
+
+               # build a single executable with symlinks
+               --disable-separate-binaries
+               --disable-separate-tools
+
+               # used purely to control/disrespect *FLAGS
+               --disable-debugging
+               --enable-new_dialect
+               --disable-optimization
+               --disable-strong-optimization
+               --disable-security
+               --disable-nopie-security
+               --disable-strong-security
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       dobashcomp bash/eix
+       systemd_dotmpfilesd tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+       if ! use prefix; then
+               # note: if this is done in src_install(), portage:portage
+               # ownership may be reset to root
+               chown portage:portage "${EROOT%/}"/var/cache/eix || die
+       fi
+
+       local obs=${EROOT%/}/var/cache/eix.previous
+       if [[ -f ${obs} ]]; then
+               ewarn "Found obsolete ${obs}, please remove it"
+       fi
+}
+
+pkg_postrm() {
+       if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+               rm -rf "${EROOT%/}/var/cache/${PN}" || die
+       fi
 }