]> git.bzium.org - embe/overlay.git/blobdiff - dev-python/cloudflare/cloudflare-2.11.6.ebuild
dev-python/jsonlines-4.0.0: bump
[embe/overlay.git] / dev-python / cloudflare / cloudflare-2.11.6.ebuild
index 5d44492be0a8c8fc43f83316ec153ca2e69e6c62..aa84274035f0b0dea3ac33bee17363040f4e37a3 100644 (file)
@@ -1,10 +1,10 @@
 # Copyright 2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=7
+EAPI=8
 
-PYTHON_COMPAT=( python3_{8..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
 inherit distutils-r1
 
 MY_PN="python-${PN}"
@@ -40,7 +40,7 @@ python_install_all() {
                docompress -x /usr/share/doc/${PF}/examples
        fi
 
-       newman cli4/cli4.man cli4.1
+       doman cli4/cli4.1
 
        distutils-r1_python_install_all
 }