]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Podbicie EAPI do 5: app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 08502e53b9f67f87b739dc543f74d022b7082c30..bc1b63bf395afb41d6b110c7d67a062c06b5aa23 100644 (file)
@@ -1,13 +1,14 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=5
 
 EGIT_REPO_URI="git://git.berlios.de/eix"
 
 WANT_LIBTOOL="none"
 
-inherit autotools git-2 multilib bash-completion-r1
+PLOCALES="de ru"
+inherit autotools git-2 bash-completion-r1 eutils multilib l10n
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -15,16 +16,18 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
 
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+RDEPEND="app-shells/push
+       sqlite? ( >=dev-db/sqlite-3 )
+       nls? ( virtual/libintl )"
 DEPEND="${RDEPEND}
+       clang? ( sys-devel/clang )
        doc? ( dev-python/docutils )
        sys-devel/gettext"
 
 src_prepare() {
+       epatch_user
        eautopoint
        eautoreconf
 }
@@ -37,6 +40,7 @@ src_configure() {
                $(use_enable strong-optimization) $(use_enable debug debugging) \
                $(use_with prefix always-accept-keywords) \
                $(use_with dep dep-default) \
+               $(use_with clang nongnu-cxx clang++) \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \