]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 08502e53b9f67f87b739dc543f74d022b7082c30..660c219fde1f1a5ccea3eadf0affb43484446eaa 100644 (file)
@@ -1,13 +1,15 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=5
 
 EGIT_REPO_URI="git://git.berlios.de/eix"
 
+WANT_AUTOMAKE="1.13"
 WANT_LIBTOOL="none"
 
-inherit autotools git-2 multilib bash-completion-r1
+PLOCALES="de ru"
+inherit autotools git-2 bash-completion-r1 eutils multilib l10n
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -15,28 +17,33 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
 
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
-DEPEND="${RDEPEND}
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+       nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+       app-shells/push"
+DEPEND="${BOTHDEPEND}
+       clang? ( sys-devel/clang )
        doc? ( dev-python/docutils )
-       sys-devel/gettext"
+       >=sys-devel/gettext-0.18.3"
 
 src_prepare() {
-       eautopoint
+       epatch_user
        eautoreconf
 }
 
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
-               $(use_with zsh-completion) \
                $(use_enable nls) $(use_enable tools separate-tools) \
                $(use_enable security) $(use_enable optimization) \
+               $(use_enable strong-security) \
                $(use_enable strong-optimization) $(use_enable debug debugging) \
+               $(use_enable swap-remote) \
                $(use_with prefix always-accept-keywords) \
                $(use_with dep dep-default) \
+               $(use_with clang nongnu-cxx clang++) \
+               --with-zsh-completion \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \