]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index be574197a10aa7100322343e4fbd1470e28d3814..4d24bd46e3a58c613caf0d6ac7a8aa531bb9c5db 100644 (file)
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=6
 
-EGIT_REPO_URI="git://git.berlios.de/eix"
+EGIT_REPO_URI="https://github.com/vaeth/eix.git"
 
 WANT_LIBTOOL="none"
 
 PLOCALES="de ru"
+inherit autotools git-r3 bash-completion-r1 l10n systemd
 
-inherit autotools git-2 bash-completion-r1 eutils multilib l10n
-
-DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
-HOMEPAGE="http://eix.berlios.de"
+DESCRIPTION="Search and query ebuilds"
+HOMEPAGE="https://github.com/vaeth/eix/"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="debug doc nls sqlite"
 
-RDEPEND="app-shells/push
-       sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
-       clang? ( sys-devel/clang )
+BOTHDEPEND="nls? ( virtual/libintl )
+       sqlite? ( >=dev-db/sqlite-3:= )"
+RDEPEND="${BOTHDEPEND}
+       >=app-shells/push-2.0
+       >=app-shells/quoter-3.0"
+DEPEND="${BOTHDEPEND}
        doc? ( dev-python/docutils )
-       sys-devel/gettext"
+       >=sys-devel/gettext-0.18.3"
+
+pkg_setup() {
+       # remove stale cache file to prevent collisions
+       local old_cache=${EROOT%/}/var/cache/${PN}
+       if [[ -f ${old_cache} ]]; then
+               rm "${old_cache}" || die
+       fi
+}
 
 src_prepare() {
-       epatch_user
-       eautopoint
+       default
+       sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
        eautoreconf
 }
 
 src_configure() {
-       econf $(use_with sqlite) $(use_with doc extra-doc) \
-               $(use_with zsh-completion) \
-               $(use_enable nls) $(use_enable tools separate-tools) \
-               $(use_enable security) $(use_enable optimization) \
-               $(use_enable strong-optimization) $(use_enable debug debugging) \
-               $(use_with prefix always-accept-keywords) \
-               $(use_with dep dep-default) \
-               $(use_with clang nongnu-cxx clang++) \
-               --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
-               --with-portage-rootpath="${ROOTPATH}" \
-               --with-eprefix-default="${EPREFIX}" \
-               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+       local myconf=(
+               $(use_enable debug paranoicasserts)
+               $(use_enable nls)
+               $(use_with doc extra-doc)
+               $(use_with sqlite)
+
+               # default configuration
+               $(use_with prefix always-accept-keywords)
+               --with-dep-default
+               --with-required-use-default
+
+               # paths
+               --with-portage-rootpath="${ROOTPATH}"
+               --with-eprefix-default="${EPREFIX}"
+
+               # build a single executable with symlinks
+               --disable-separate-binaries
+               --disable-separate-tools
+
+               # used purely to control/disrespect *FLAGS
+               --disable-debugging
+               --enable-new_dialect
+               --disable-optimization
+               --disable-strong-optimization
+               --disable-security
+               --disable-nopie-security
+               --disable-strong-security
+       )
+
+       econf "${myconf[@]}"
 }
 
 src_install() {
        default
        dobashcomp bash/eix
-       keepdir "/var/cache/${PN}"
-       fowners portage:portage "/var/cache/${PN}"
-       fperms 775 "/var/cache/${PN}"
+       systemd_dotmpfilesd tmpfiles.d/eix.conf
 }
 
 pkg_postinst() {
-       # fowners in src_install doesn't work for owner/group portage:
-       # merging changes this owner/group back to root.
-       use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
-       local obs="${EROOT}var/cache/eix.previous"
-       ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+       if ! use prefix; then
+               # note: if this is done in src_install(), portage:portage
+               # ownership may be reset to root
+               chown portage:portage "${EROOT%/}"/var/cache/eix || die
+       fi
+
+       local obs=${EROOT%/}/var/cache/eix.previous
+       if [[ -f ${obs} ]]; then
+               ewarn "Found obsolete ${obs}, please remove it"
+       fi
+}
+
+pkg_postrm() {
+       if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
+               rm -rf "${EROOT%/}/var/cache/${PN}" || die
+       fi
 }