]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 64df38b6edc752384043d5939b42ac9f134489ce..660c219fde1f1a5ccea3eadf0affb43484446eaa 100644 (file)
@@ -1,14 +1,15 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=5
 
 EGIT_REPO_URI="git://git.berlios.de/eix"
-EGIT_BOOTSTRAP="autogen.sh"
 
+WANT_AUTOMAKE="1.13"
 WANT_LIBTOOL="none"
 
-inherit autotools git-2 multilib bash-completion-r1
+PLOCALES="de ru"
+inherit autotools git-2 bash-completion-r1 eutils multilib l10n
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -16,23 +17,33 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
 
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
-DEPEND="${RDEPEND}
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+       nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+       app-shells/push"
+DEPEND="${BOTHDEPEND}
+       clang? ( sys-devel/clang )
        doc? ( dev-python/docutils )
-       sys-devel/gettext"
+       >=sys-devel/gettext-0.18.3"
+
+src_prepare() {
+       epatch_user
+       eautoreconf
+}
 
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
-               $(use_with zsh-completion) \
                $(use_enable nls) $(use_enable tools separate-tools) \
                $(use_enable security) $(use_enable optimization) \
+               $(use_enable strong-security) \
                $(use_enable strong-optimization) $(use_enable debug debugging) \
+               $(use_enable swap-remote) \
                $(use_with prefix always-accept-keywords) \
                $(use_with dep dep-default) \
+               $(use_with clang nongnu-cxx clang++) \
+               --with-zsh-completion \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \
@@ -43,6 +54,15 @@ src_configure() {
 src_install() {
        default
        dobashcomp bash/eix
-       keepdir /var/cache/eix
-       fowners portage:portage /var/cache/eix
+       keepdir "/var/cache/${PN}"
+       fowners portage:portage "/var/cache/${PN}"
+       fperms 775 "/var/cache/${PN}"
+}
+
+pkg_postinst() {
+       # fowners in src_install doesn't work for owner/group portage:
+       # merging changes this owner/group back to root.
+       use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       local obs="${EROOT}var/cache/eix.previous"
+       ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
 }