]> git.bzium.org - embe/overlay.git/blobdiff - dev-python/jsonlines/jsonlines-4.0.0.ebuild
dev-python/jsonlines-4.0.0: bump
[embe/overlay.git] / dev-python / jsonlines / jsonlines-4.0.0.ebuild
similarity index 64%
rename from dev-python/jsonlines/jsonlines-3.0.0-r1.ebuild
rename to dev-python/jsonlines/jsonlines-4.0.0.ebuild
index cb8939422b9d56c1998c140a0c997ed6b886f467..27c69635ca581ce5b9a55c1b805cab1e5985f79a 100644 (file)
@@ -1,19 +1,20 @@
-# Copyright 2020 Gentoo Authors
+# Copyright 2024 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=8
 
-PYTHON_COMPAT=( python3_{9..11} )
 DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
 inherit distutils-r1
 
 DESCRIPTION="Python library to simplify working with jsonlines and ndjson data"
 HOMEPAGE="https://github.com/wbolster/jsonlines"
-SRC_URI="https://github.com/wbolster/jsonlines/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="https://github.com/wbolster/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="BSD"
 SLOT="0"
 KEYWORDS="~amd64"
+RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
 
-distutils_enable_tests pytest
 distutils_enable_sphinx doc
+distutils_enable_tests pytest