]> git.bzium.org - embe/overlay.git/blobdiff - www-apps/bzium-lister/bzium-lister-0.1.0.ebuild
www-apps/bzium-lister: Python 3.8 support
[embe/overlay.git] / www-apps / bzium-lister / bzium-lister-0.1.0.ebuild
index 1b015355ad26d595c1ed649dfd5c58e6d7ed0b48..56dc75396ecef3efe25aed7c82908310a3a5adad 100644 (file)
@@ -1,6 +1,6 @@
 EAPI=7
 
-PYTHON_COMPAT=( python3_9 )
+PYTHON_COMPAT=( python3_{8,9} )
 inherit distutils-r1
 
 MY_PN="${PN/-/.}"
@@ -22,6 +22,7 @@ RDEPEND="
        dev-python/toml[${PYTHON_USEDEP}]
        dev-python/jinja[${PYTHON_USEDEP}]
        dev-python/PyICU[${PYTHON_USEDEP}]
+       $(python_gen_cond_dep 'dev-python/backports-zoneinfo[${PYTHON_USEDEP}]' python3_8)
 "
 
 python_prepare_all()