]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Podbicie EAPI do 5: app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index c471891545ea8e318bcec62bd35e6a30dbec0fe7..bc1b63bf395afb41d6b110c7d67a062c06b5aa23 100644 (file)
@@ -1,14 +1,14 @@
 # Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=5
 
 EGIT_REPO_URI="git://git.berlios.de/eix"
-EGIT_BOOTSTRAP="autogen.sh"
 
 WANT_LIBTOOL="none"
 
-inherit autotools git-2 multilib bash-completion-r1
+PLOCALES="de ru"
+inherit autotools git-2 bash-completion-r1 eutils multilib l10n
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -16,15 +16,22 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="clang debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
 
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
+RDEPEND="app-shells/push
+       sqlite? ( >=dev-db/sqlite-3 )
+       nls? ( virtual/libintl )"
 DEPEND="${RDEPEND}
+       clang? ( sys-devel/clang )
        doc? ( dev-python/docutils )
        sys-devel/gettext"
 
+src_prepare() {
+       epatch_user
+       eautopoint
+       eautoreconf
+}
+
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
                $(use_with zsh-completion) \
@@ -32,7 +39,8 @@ src_configure() {
                $(use_enable security) $(use_enable optimization) \
                $(use_enable strong-optimization) $(use_enable debug debugging) \
                $(use_with prefix always-accept-keywords) \
-               --without-bzip2 \
+               $(use_with dep dep-default) \
+               $(use_with clang nongnu-cxx clang++) \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \
@@ -43,4 +51,15 @@ src_configure() {
 src_install() {
        default
        dobashcomp bash/eix
+       keepdir "/var/cache/${PN}"
+       fowners portage:portage "/var/cache/${PN}"
+       fperms 775 "/var/cache/${PN}"
+}
+
+pkg_postinst() {
+       # fowners in src_install doesn't work for owner/group portage:
+       # merging changes this owner/group back to root.
+       use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       local obs="${EROOT}var/cache/eix.previous"
+       ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
 }