]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Zależności w app-portage/eix
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index c471891545ea8e318bcec62bd35e6a30dbec0fe7..c4ac10141d16cdcee0ab9d8f2a45a6490804e692 100644 (file)
@@ -1,46 +1,68 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=4
+EAPI=6
 
-EGIT_REPO_URI="git://git.berlios.de/eix"
-EGIT_BOOTSTRAP="autogen.sh"
+EGIT_REPO_URI="https://github.com/vaeth/eix.git"
 
 WANT_LIBTOOL="none"
 
-inherit autotools git-2 multilib bash-completion-r1
+PLOCALES="de ru"
+inherit autotools git-r3 bash-completion-r1 l10n systemd
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
-HOMEPAGE="http://eix.berlios.de"
+HOMEPAGE="https://github.com/vaeth/eix/"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
 
-RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
-       nls? ( virtual/libintl )
-       zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
-DEPEND="${RDEPEND}
+BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
+       nls? ( virtual/libintl )"
+RDEPEND="${BOTHDEPEND}
+       >=app-shells/push-2.0
+       >=app-shells/quoter-3.0"
+DEPEND="${BOTHDEPEND}
        doc? ( dev-python/docutils )
-       sys-devel/gettext"
+       >=sys-devel/gettext-0.18.3"
+
+src_prepare() {
+       sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+       eapply_user
+       eautoreconf
+}
 
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
-               $(use_with zsh-completion) \
                $(use_enable nls) $(use_enable tools separate-tools) \
                $(use_enable security) $(use_enable optimization) \
+               $(use_enable strong-security) \
                $(use_enable strong-optimization) $(use_enable debug debugging) \
+               $(use_enable swap-remote) \
                $(use_with prefix always-accept-keywords) \
-               --without-bzip2 \
-               --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
+               $(use_with dep dep-default) \
+               $(use_with required-use required-use-default) \
+               --with-zsh-completion \
                --with-portage-rootpath="${ROOTPATH}" \
-               --with-eprefix-default="${EPREFIX}" \
-               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+               --with-eprefix-default="${EPREFIX}"
 }
 
 src_install() {
        default
        dobashcomp bash/eix
+       systemd_dotmpfilesd tmpfiles.d/eix.conf
+}
+
+pkg_postinst() {
+       test -d "${EROOT}var/cache/${PN}" || {
+               mkdir "${EROOT}var/cache/${PN}"
+               use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       }
+       local obs="${EROOT}var/cache/eix.previous"
+       ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
+}
+
+pkg_postrm() {
+       [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
 }