]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index e5e3ccdc79dbbb24ce70ad5f1886b5489b2989fa..22545fd00db0887a4a9c873abb7d782f783b0fe2 100644 (file)
@@ -1,14 +1,14 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="4"
+EAPI=4
 
-ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
-ESVN_BOOTSTRAP="./autogen.sh"
+EGIT_REPO_URI="git://git.berlios.de/eix"
+EGIT_BOOTSTRAP="autogen.sh"
 
-WANT_AUTOMAKE="1.11"
+WANT_LIBTOOL="none"
 
-inherit autotools multilib subversion
+inherit autotools git-2 multilib bash-completion-r1
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -16,26 +16,46 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
+IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
 
-RDEPEND="sqlite? ( dev-db/sqlite:3 )
+RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
        nls? ( virtual/libintl )
-       bzip2? ( app-arch/bzip2 )
        zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
 DEPEND="${RDEPEND}
        doc? ( dev-python/docutils )
        sys-devel/gettext"
 
 src_configure() {
-       econf $(use_with bzip2) $(use_with sqlite) $(use_with doc extra-doc) \
+       econf $(use_with sqlite) $(use_with doc extra-doc) \
                $(use_with zsh-completion) \
                $(use_enable nls) $(use_enable tools separate-tools) \
-               $(use_enable hardened security) $(use_enable optimization) \
+               $(use_enable security) $(use_enable optimization) \
                $(use_enable strong-optimization) $(use_enable debug debugging) \
                $(use_with prefix always-accept-keywords) \
+               $(use_with dep dep-default) \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \
                --docdir="${EPREFIX}/usr/share/doc/${PF}" \
                --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
 }
+
+src_install() {
+       default
+       dobashcomp bash/eix
+       keepdir /var/cache/eix
+       fowners portage:portage /var/cache/eix
+}
+
+pkg_preinst() {
+       for file in "${EROOT}"/var/cache/eix{,.previous}
+       do
+               [ ! -f "${file}" ] && continue
+               rm "${file}" || die "Removing ${file} failed."
+       done
+}
+
+pkg_postinst() {
+       # src_install zmienia portage na root
+       chown portage:portage "${EROOT}/var/cache/eix"
+}