]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Aktualizacja app-portage/eix-9999
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 0093a53c6cf34c67a5cc1a84cfc3adc7db36740a..08502e53b9f67f87b739dc543f74d022b7082c30 100644 (file)
@@ -1,14 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=4
 
-ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
-ESVN_BOOTSTRAP="./autogen.sh"
+EGIT_REPO_URI="git://git.berlios.de/eix"
 
-WANT_AUTOMAKE="1.11"
+WANT_LIBTOOL="none"
 
-inherit autotools multilib subversion bash-completion-r1
+inherit autotools git-2 multilib bash-completion-r1
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
 HOMEPAGE="http://eix.berlios.de"
@@ -16,7 +15,7 @@ HOMEPAGE="http://eix.berlios.de"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
+IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
 
 RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
        nls? ( virtual/libintl )
@@ -25,6 +24,11 @@ DEPEND="${RDEPEND}
        doc? ( dev-python/docutils )
        sys-devel/gettext"
 
+src_prepare() {
+       eautopoint
+       eautoreconf
+}
+
 src_configure() {
        econf $(use_with sqlite) $(use_with doc extra-doc) \
                $(use_with zsh-completion) \
@@ -32,6 +36,7 @@ src_configure() {
                $(use_enable security) $(use_enable optimization) \
                $(use_enable strong-optimization) $(use_enable debug debugging) \
                $(use_with prefix always-accept-keywords) \
+               $(use_with dep dep-default) \
                --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
                --with-eprefix-default="${EPREFIX}" \
@@ -42,4 +47,15 @@ src_configure() {
 src_install() {
        default
        dobashcomp bash/eix
+       keepdir "/var/cache/${PN}"
+       fowners portage:portage "/var/cache/${PN}"
+       fperms 775 "/var/cache/${PN}"
+}
+
+pkg_postinst() {
+       # fowners in src_install doesn't work for owner/group portage:
+       # merging changes this owner/group back to root.
+       use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       local obs="${EROOT}var/cache/eix.previous"
+       ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
 }