]> git.bzium.org - embe/overlay.git/blobdiff - app-portage/eix/eix-9999.ebuild
Zależności w app-portage/eix
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
index 78d0bff8221103f5878a6a0fccd0b6554e50c48f..c4ac10141d16cdcee0ab9d8f2a45a6490804e692 100644 (file)
@@ -1,34 +1,35 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=6
 
-EGIT_REPO_URI="git://git.berlios.de/eix"
+EGIT_REPO_URI="https://github.com/vaeth/eix.git"
 
-WANT_AUTOMAKE="1.13"
 WANT_LIBTOOL="none"
 
 PLOCALES="de ru"
-inherit autotools git-2 bash-completion-r1 eutils multilib l10n
+inherit autotools git-r3 bash-completion-r1 l10n systemd
 
 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
-HOMEPAGE="http://eix.berlios.de"
+HOMEPAGE="https://github.com/vaeth/eix/"
 
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
+IUSE="debug +dep doc nls optimization +required-use security strong-optimization strong-security sqlite swap-remote tools"
 
 BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
        nls? ( virtual/libintl )"
 RDEPEND="${BOTHDEPEND}
-       app-shells/push"
+       >=app-shells/push-2.0
+       >=app-shells/quoter-3.0"
 DEPEND="${BOTHDEPEND}
        doc? ( dev-python/docutils )
        >=sys-devel/gettext-0.18.3"
 
 src_prepare() {
-       epatch_user
+       sed -i -e "s'/'${EPREFIX}/'" -- "${S}"/tmpfiles.d/eix.conf || die
+       eapply_user
        eautoreconf
 }
 
@@ -41,26 +42,27 @@ src_configure() {
                $(use_enable swap-remote) \
                $(use_with prefix always-accept-keywords) \
                $(use_with dep dep-default) \
+               $(use_with required-use required-use-default) \
                --with-zsh-completion \
-               --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
                --with-portage-rootpath="${ROOTPATH}" \
-               --with-eprefix-default="${EPREFIX}" \
-               --docdir="${EPREFIX}/usr/share/doc/${PF}" \
-               --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+               --with-eprefix-default="${EPREFIX}"
 }
 
 src_install() {
        default
        dobashcomp bash/eix
-       keepdir "/var/cache/${PN}"
-       fowners portage:portage "/var/cache/${PN}"
-       fperms 775 "/var/cache/${PN}"
+       systemd_dotmpfilesd tmpfiles.d/eix.conf
 }
 
 pkg_postinst() {
-       # fowners in src_install doesn't work for owner/group portage:
-       # merging changes this owner/group back to root.
-       use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       test -d "${EROOT}var/cache/${PN}" || {
+               mkdir "${EROOT}var/cache/${PN}"
+               use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
+       }
        local obs="${EROOT}var/cache/eix.previous"
        ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"
 }
+
+pkg_postrm() {
+       [ -n "${REPLACED_BY_VERSION}" ] || rm -rf -- "${EROOT}var/cache/${PN}"
+}