]> git.bzium.org - embe/overlay.git/blob - app-portage/eix/eix-9999.ebuild
c471891545ea8e318bcec62bd35e6a30dbec0fe7
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=4
5
6 EGIT_REPO_URI="git://git.berlios.de/eix"
7 EGIT_BOOTSTRAP="autogen.sh"
8
9 WANT_LIBTOOL="none"
10
11 inherit autotools git-2 multilib bash-completion-r1
12
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="http://eix.berlios.de"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
20
21 RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
22         nls? ( virtual/libintl )
23         zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
24 DEPEND="${RDEPEND}
25         doc? ( dev-python/docutils )
26         sys-devel/gettext"
27
28 src_configure() {
29         econf $(use_with sqlite) $(use_with doc extra-doc) \
30                 $(use_with zsh-completion) \
31                 $(use_enable nls) $(use_enable tools separate-tools) \
32                 $(use_enable security) $(use_enable optimization) \
33                 $(use_enable strong-optimization) $(use_enable debug debugging) \
34                 $(use_with prefix always-accept-keywords) \
35                 --without-bzip2 \
36                 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
37                 --with-portage-rootpath="${ROOTPATH}" \
38                 --with-eprefix-default="${EPREFIX}" \
39                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
40                 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
41 }
42
43 src_install() {
44         default
45         dobashcomp bash/eix
46 }