]> git.bzium.org - embe/overlay.git/blob - app-portage/eix/eix-9999.ebuild
2fe3a50f770a4789db2d918ef9fab3ec6b300954
[embe/overlay.git] / app-portage / eix / eix-9999.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI="4"
5
6 ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
7 ESVN_BOOTSTRAP="./autogen.sh"
8
9 WANT_AUTOMAKE="1.11"
10
11 inherit autotools multilib subversion
12
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="http://eix.berlios.de"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS=""
19 IUSE="bzip2 debug doc hardened nls optimization strong-optimization sqlite tools zsh-completion"
20
21 RDEPEND="sqlite? ( dev-db/sqlite:3 )
22         nls? ( virtual/libintl )
23         bzip2? ( app-arch/bzip2 )
24         zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
25 DEPEND="${RDEPEND}
26         doc? ( dev-python/docutils )
27         sys-devel/gettext"
28
29 src_configure() {
30         econf $(use_with bzip2) $(use_with sqlite) $(use_with doc extra-doc) \
31                 $(use_with zsh-completion) \
32                 $(use_enable nls) $(use_enable tools separate-tools) \
33                 $(use_enable hardened security) $(use_enable optimization) \
34                 $(use_enable strong-optimization) $(use_enable debug debugging) \
35                 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
36                 --with-portage-rootpath="${ROOTPATH}" \
37                 --with-eprefix-default="${EPREFIX}" \
38                 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
39                 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
40 }