1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
6 PYTHON_COMPAT=( python3_6 )
7 PYTHON_REQ_USE="sqlite"
9 inherit eutils python-single-r1 xdg
11 DESCRIPTION="A spaced-repetition memory training program (flash cards)"
12 HOMEPAGE="https://apps.ankiweb.net"
13 SRC_URI="https://apps.ankiweb.net/downloads/current/${P}-source.tgz -> ${P}.tgz"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="latex +recording +sound test"
21 RESTRICT="!test? ( test )"
22 REQUIRED_USE="${PYTHON_REQUIRED_USE}"
24 RDEPEND="${PYTHON_DEPS}
25 $(python_gen_cond_dep '
28 >=dev-python/PyQt5-5.12[gui,svg,widgets,${PYTHON_MULTI_USEDEP}]
29 dev-python/PyQtWebEngine[${PYTHON_MULTI_USEDEP}]
31 <dev-python/PyQt5-5.12[gui,svg,webengine,widgets,${PYTHON_MULTI_USEDEP}]
33 >=dev-python/httplib2-0.7.4[${PYTHON_MULTI_USEDEP}]
34 dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
35 dev-python/decorator[${PYTHON_MULTI_USEDEP}]
36 dev-python/markdown[${PYTHON_MULTI_USEDEP}]
37 dev-python/requests[${PYTHON_MULTI_USEDEP}]
38 dev-python/send2trash[${PYTHON_MULTI_USEDEP}]
40 recording? ( media-sound/lame )
41 sound? ( media-video/mpv )
49 $(python_gen_cond_dep '
50 dev-python/nose[${PYTHON_MULTI_USEDEP}]
55 PATCHES=( "${FILESDIR}"/${PN}-2.1.0_beta25-web-folder.patch )
58 python-single-r1_pkg_setup
63 sed -i -e "s/updates=True/updates=False/" \
64 aqt/profiles.py || die
72 sed -e "s:nose=nosetests$:nose=\"${EPYTHON} ${EROOT}usr/bin/nosetests\":" \
73 -i tools/tests.sh || die
74 sed -e "s:nose=nosetests3$:nose=\"${EPYTHON} ${EROOT}usr/bin/nosetests3\":" \
75 -i tools/tests.sh || die
76 sed -e "s:which nosetests3:which ${EROOT}usr/bin/nosetests3:" \
77 -i tools/tests.sh || die
78 ./tools/tests.sh || die
86 dodoc README.md README.development
87 python_domodule aqt anki
88 python_newscript runanki anki
90 # Localization files go into the anki directory:
91 python_moduleinto anki
92 python_domodule locale
94 # not sure if this is correct, but
95 # site-packages/aqt/mediasrv.py wants the directory
96 insinto /usr/share/anki