1 # Copyright 1999-2014 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="git://git.berlios.de/eix"
12 inherit autotools git-2 bash-completion-r1 eutils multilib l10n
14 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
15 HOMEPAGE="http://eix.berlios.de"
20 IUSE="debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
22 BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
23 nls? ( virtual/libintl )"
24 RDEPEND="${BOTHDEPEND}
27 doc? ( dev-python/docutils )
28 >=sys-devel/gettext-0.18.3"
36 econf $(use_with sqlite) $(use_with doc extra-doc) \
37 $(use_enable nls) $(use_enable tools separate-tools) \
38 $(use_enable security) $(use_enable optimization) \
39 $(use_enable strong-security) \
40 $(use_enable strong-optimization) $(use_enable debug debugging) \
41 $(use_enable swap-remote) \
42 $(use_with prefix always-accept-keywords) \
43 $(use_with dep dep-default) \
44 --with-zsh-completion \
45 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
46 --with-portage-rootpath="${ROOTPATH}" \
47 --with-eprefix-default="${EPREFIX}" \
48 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
49 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
55 keepdir "/var/cache/${PN}"
56 fowners portage:portage "/var/cache/${PN}"
57 fperms 775 "/var/cache/${PN}"
61 # fowners in src_install doesn't work for owner/group portage:
62 # merging changes this owner/group back to root.
63 use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
64 local obs="${EROOT}var/cache/eix.previous"
65 ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"