1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="git://git.berlios.de/eix"
12 inherit autotools git-2 bash-completion-r1 eutils multilib l10n
14 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
15 HOMEPAGE="http://eix.berlios.de"
20 IUSE="clang debug +dep doc nls optimization security strong-optimization strong-security sqlite swap-remote tools"
22 BOTHDEPEND="sqlite? ( >=dev-db/sqlite-3 )
23 nls? ( virtual/libintl )"
24 RDEPEND="${BOTHDEPEND}
27 clang? ( sys-devel/clang )
28 doc? ( dev-python/docutils )
29 >=sys-devel/gettext-0.18.3"
37 econf $(use_with sqlite) $(use_with doc extra-doc) \
38 $(use_enable nls) $(use_enable tools separate-tools) \
39 $(use_enable security) $(use_enable optimization) \
40 $(use_enable strong-security) \
41 $(use_enable strong-optimization) $(use_enable debug debugging) \
42 $(use_enable swap-remote) \
43 $(use_with prefix always-accept-keywords) \
44 $(use_with dep dep-default) \
45 $(use_with clang nongnu-cxx clang++) \
46 --with-zsh-completion \
47 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
48 --with-portage-rootpath="${ROOTPATH}" \
49 --with-eprefix-default="${EPREFIX}" \
50 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
51 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
57 keepdir "/var/cache/${PN}"
58 fowners portage:portage "/var/cache/${PN}"
59 fperms 775 "/var/cache/${PN}"
63 # fowners in src_install doesn't work for owner/group portage:
64 # merging changes this owner/group back to root.
65 use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
66 local obs="${EROOT}var/cache/eix.previous"
67 ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"