1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="https://github.com/vaeth/eix.git"
11 inherit autotools git-r3 bash-completion-r1 l10n systemd
13 DESCRIPTION="Search and query ebuilds"
14 HOMEPAGE="https://github.com/vaeth/eix/"
19 IUSE="debug doc nls sqlite"
21 BOTHDEPEND="nls? ( virtual/libintl )
22 sqlite? ( >=dev-db/sqlite-3:= )"
23 RDEPEND="${BOTHDEPEND}
25 >=app-shells/quoter-3.0"
27 doc? ( dev-python/docutils )
28 >=sys-devel/gettext-0.18.3"
31 # remove stale cache file to prevent collisions
32 local old_cache=${EROOT%/}/var/cache/${PN}
33 if [[ -f ${old_cache} ]]; then
34 rm "${old_cache}" || die
40 sed -i -e "s:/:${EPREFIX}/:" tmpfiles.d/eix.conf || die
46 $(use_enable debug paranoicasserts)
48 $(use_with doc extra-doc)
51 # default configuration
52 $(use_with prefix always-accept-keywords)
54 --with-required-use-default
57 --with-portage-rootpath="${ROOTPATH}"
58 --with-eprefix-default="${EPREFIX}"
60 # build a single executable with symlinks
61 --disable-separate-binaries
62 --disable-separate-tools
64 # used purely to control/disrespect *FLAGS
67 --disable-optimization
68 --disable-strong-optimization
70 --disable-nopie-security
71 --disable-strong-security
80 systemd_dotmpfilesd tmpfiles.d/eix.conf
85 # note: if this is done in src_install(), portage:portage
86 # ownership may be reset to root
87 chown portage:portage "${EROOT%/}"/var/cache/eix || die
90 local obs=${EROOT%/}/var/cache/eix.previous
91 if [[ -f ${obs} ]]; then
92 ewarn "Found obsolete ${obs}, please remove it"
97 if [[ ! -n ${REPLACED_BY_VERSION} ]]; then
98 rm -rf "${EROOT%/}/var/cache/${PN}" || die