1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
5 PYTHON_COMPAT=( python3_{6,7,8,9} )
6 DISTUTILS_USE_SETUPTOOLS=rdepend
10 DESCRIPTION="Cloudflare DNS Authenticator plugin for Certbot (Let's Encrypt Client)"
11 HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
12 SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> ${P}.tar.gz"
13 S=${WORKDIR}/certbot-${PV}/${PN}
20 app-crypt/acme[${PYTHON_USEDEP}]
21 app-crypt/certbot[${PYTHON_USEDEP}]
22 dev-python/cloudflare[${PYTHON_USEDEP}]
23 dev-python/zope-interface[${PYTHON_USEDEP}]
26 distutils_enable_tests pytest
27 distutils_enable_sphinx docs dev-python/sphinx_rtd_theme