1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 EGIT_REPO_URI="git://git.berlios.de/eix"
10 inherit autotools git-2 multilib bash-completion-r1
12 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
13 HOMEPAGE="http://eix.berlios.de"
18 IUSE="debug +dep doc nls optimization security strong-optimization sqlite tools zsh-completion"
20 RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
21 nls? ( virtual/libintl )
22 zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
24 doc? ( dev-python/docutils )
33 econf $(use_with sqlite) $(use_with doc extra-doc) \
34 $(use_with zsh-completion) \
35 $(use_enable nls) $(use_enable tools separate-tools) \
36 $(use_enable security) $(use_enable optimization) \
37 $(use_enable strong-optimization) $(use_enable debug debugging) \
38 $(use_with prefix always-accept-keywords) \
39 $(use_with dep dep-default) \
40 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
41 --with-portage-rootpath="${ROOTPATH}" \
42 --with-eprefix-default="${EPREFIX}" \
43 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
44 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
50 keepdir "/var/cache/${PN}"
51 fowners portage:portage "/var/cache/${PN}"
52 fperms 775 "/var/cache/${PN}"
56 # fowners in src_install doesn't work for owner/group portage:
57 # merging changes this owner/group back to root.
58 use prefix || chown portage:portage "${EROOT}var/cache/${PN}"
59 local obs="${EROOT}var/cache/eix.previous"
60 ! test -f "${obs}" || ewarn "Found obsolete ${obs}, please remove it"