1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 ESVN_REPO_URI="https://svn.gentooexperimental.org/eix/trunk/"
7 ESVN_BOOTSTRAP="./autogen.sh"
11 inherit autotools multilib subversion bash-completion-r1
13 DESCRIPTION="Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more"
14 HOMEPAGE="http://eix.berlios.de"
19 IUSE="debug doc nls optimization security strong-optimization sqlite tools zsh-completion"
21 RDEPEND="sqlite? ( >=dev-db/sqlite-3 )
22 nls? ( virtual/libintl )
23 zsh-completion? ( !!<app-shells/zsh-completion-20091203-r1 )"
25 doc? ( dev-python/docutils )
29 econf $(use_with sqlite) $(use_with doc extra-doc) \
30 $(use_with zsh-completion) \
31 $(use_enable nls) $(use_enable tools separate-tools) \
32 $(use_enable security) $(use_enable optimization) \
33 $(use_enable strong-optimization) $(use_enable debug debugging) \
34 $(use_with prefix always-accept-keywords) \
35 --with-ebuild-sh-default="/usr/$(get_libdir)/portage/bin/ebuild.sh" \
36 --with-portage-rootpath="${ROOTPATH}" \
37 --with-eprefix-default="${EPREFIX}" \
38 --docdir="${EPREFIX}/usr/share/doc/${PF}" \
39 --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"